Use more than one DHCP pool (uBR10K) |

You are here

Use more than one DHCP pool (uBR10K)

8 posts / 0 new
Last post
Use more than one DHCP pool (uBR10K)
Plain text icon cmts_config_11_06_17.txt17.88 KB

Hey everyone, my setup contains:
a. Cisco uBR10000 chassis (Version 12.2(33)SCG6, RELEASE SOFTWARE (fc1))
b. One MC20X20 I-CMTS 20DSX20US CLC Module
c. Cisco CNPR (Running version 8.3.4)

I have CM's ( network) pool and CPE's ( network) pool configured at my CNPR.
I want somehow to set new DHCP pool that will provide Public IP addresses to several CPE's that i will choose (by MAC address).

1. Which options do I have to filtered only wanted CPE's? (e.g. select CPE by MAC address is the best option)
2. How my DHCP server (CNPR) will know to allocate IP from different pool? By bundle1 secondary IP address?

*Attached CMTS config to the topic
**that's my first topic at forum :) Hope to get more and more involve.

You need to update your CMTS

You need to update your CMTS like this :

interface Bundle1
ip address x.x.x.0 secondary !---- CPE public
ip address secondary !---- CPE private
ip address !---- CM
cable dhcp-giaddr policy

Next you need to update your DHCP server

Sorry I forget the exact CNR terminology, but here are some rough descriptions of how to go about it :
* create a scope for the CM, example name cm, subnet
I would add CM MAC reservations and client entries for each known modem.
Plus I would setup a small range within this subnet for unknown modems to land, attach a "disabled" default policy to that small range.
* create a scope for the private CPE, example name cpe_private, subnet, range to 127
* create a scope for the public CPE, example name cpe_public, subnet x.x.x.0/24, no range
* for customers who should receive public IP, add a reservation within x.x.x.0 for their CPE MAC
* for customers who should receive private IP, don't add any CPE MAC reservations. CPE will then 'fall through' into the 10.210.18.x dynamic pool

Hi mbowe, thanks for your

Hi mbowe, thanks for your replay.

I have set the commands on interface Bundle1, but the DHCP discovers are always going through ip and not the public IP that i have set as seconday.
Which place could change the CPE to exit through the right Secondary address of bundle1 if i have several, such at my case.

The giaddr selection is by the DHCP options of the CM?

I believe that going via 10

I believe that going via is normal. The CM doesn't have an IP yet so the DISCOVER just goes through the first secondary subnet from the bundle.

if you have a CPE reservation in the public subnet. that is what will be OFFERed

if there are no CPE reservations, then the OFFER will be made from the private range

Maybe you can configure must

Maybe you can configure must-have rules for each ip pool on your dhcp server.
modem pool : dhcp option 60 = docsis
mta pool : dhcp option 60 = pktc
cpe pool : rest or not docsis and not packetcable
You can start wireshark and check dhcp discover messages on your server.



long time since the last time I used CNR, but it seems that you need to create a Client-Class to differentiate CM/CPE/Other. Then you can associate each IP Scope to the Client-Class it belongs.

Also, there are CMTSs where the request is always sent from the primary IP of the lowest bundle. It is up to the DHCP to figure out what to do with the request.

Hope it helps.



Thank you, but it i dk which the CNR ignoring my reservation..

Although I'm reserving an IP address on DMZ_scope.. the CPE gets an IP address from the regular scope (CPE_scope).
See attached screenshot.

File attachments: 

Now it is working, the things i needed is:
1. On the Edit DHCP Server page, enable the client-class attribute.
2. Setting Selection Tags on Scopes and Prefixes.
See page:

Thank you all for you assistant

Log in or register to post comments