Depi tunnel problems. | docsis.org

You are here

Depi tunnel problems.

7 posts / 0 new
Last post
drwho17
Depi tunnel problems.

I am having trouble establishing Depi Session's between a SPA-DOCSIS-HD-V1 on a Ciscom UBR 10012 and Cisco RFGW-1 EQAM.

I've used the RFGW-1 for years, hooked up to 3GV60 and SPA-24 hooked to the RFGW-1 directly no switches. Now I'm trying to use the higher density SPA cards (144) downtreams with a 10 Gbps port. I've configured the 10 Gbps DEPI interface on the CMTS with an IP address (10.0.12.1/30) and the RFGW1 with an IP address (10.0.12.2/30), this is connected through a Cisco 6509 switch because the new SPA cards only have a 10 Gb interface and the RFGW only have a 1 GB interface. I just have the Cisco configured as a switchport and both ports on the same VLAN.

The depi tunnel comes up and looks good on both side, however I only get 2 sessions to come up (out of the 16 I have activated, assigned to ports 3.1/3.2 on the RFGW). Each reboot of the RFGW brings up two different channels/TSID's on the unit, and always they are on two disparate cards, one will be on 3.1 and one will be on 3.2, but not the same channel/TSID. A snippet below, 1340, 1337 are up, the other channels keep trying with the wicrp thing and

1252062951 3 744082397 1340 est 00:00:19 448 P
1252054111 0 744082397 1341 wicrp 00:00:00 449 P
1252028884 0 744082397 1333 wicrp 00:00:00 441 P
1252004229 2 744082397 1337 est 00:00:21 445 P

The other channels that won't come up keep coming up with this, up and down immediately.
Aug 3 10:59:25: %DEPI-6-SESSION_UP: Depi session Modular-Cable3/3/5:11, changed state to up
Aug 3 10:59:25: %DEPI-6-SESSION_DOWN: Depi session Modular-Cable3/3/5:11, changed state to down, reason: recv CDN

mbowe
When an EQ shuts the tunnel,

When an EQ shuts the tunnel, it means it isn't happy with one of the RF configurations/parameters the CMTS is sending

Eg frequency, power level, annex, interleave etc

drwho17
Yes, thanks for the response,

Yes, thanks for the response, I don't think the SPA-6 144 downstream cards with 10 G ports only works exactly well with the RF1G. I was able to get it to work, by changing to DEPI-REMOTE and manually configuring the RFGW-1, matching the settings from the UBR 10012. DEPI-LEARN appeared to work a little bit, but nothing would come out the RF-Port, but the DEPI-SESSIONS looked good.

If anybody has any ideas if DEPI-LEARN works between the SPA 6 and the RFGW1, please advise on the trick, because I'd much rather use Depi-Learn and control everything on the CMTS.

mbowe
Surprises me a bit

Surprises me a bit

I would have thought the SPA72 and SPA144 are just using similar chips/code to the SPA24 and 3G60

But I haven't personally tried these SPAs yet. So cant say for sure.

drwho17
Could be the switch in

Could be the switch in between, typically I run straight from the SPA24 1 GB or 3GX60V 1 GB to the RFGW-1 1 GB ports. Can't find much info on it.

10 Gb port on SPA6 -> into Cisco 6509 10G > VLAN -> out Cisco 6509 1G -> 1 Gb port on RF-Gateway.

Basically using the 6509 as a transceiver to take the 10 Gb out to multiple 1 Gb links to the RFGW1's.

mbowe
I have SPA-144 working OK

I have SPA-144 working OK with NSG9000-40G edgeqam
I am using 10G port on SPA-144, to a 10G switch, to 10G port on edgeqam.
The switch isn't 100% necessary, but it does allow me flexibility in remotely mapping different SPA cards to different edgeqam uplink ports.
I have multiple NSG9000-40G connected to the switch.

A few notes about configuration :
* The SPA-144 card has 6 x controllers (eg modular-cable 3/0/0, 3/0/1, 3/0/2, 3/0/3, 3/0/4, 3/0/5)
* Any bonding group may only consist of channels from controllers 1,2,3 or 4,5,6.
* On my system I am creating 72 channel bonding groups
* Each controller has to be mapped to a host card eg modular-host subslot 5/0. All 6 controllers can go to the same host card. The host card is the one where you will configure the mac-domain (primary downstream channels, upstream channels etc)
* I use a /30 between CMTS (eg interface ten3/0/0) and the edgeqam. I put this interface into a VRF to keep it out of the global routing table.
* Each SPA controller defaults to downstream channel-id 217 through 240. If you are making > 24 channel bonding groups then you need to override these channel ids to make them all unique. In my case with 72 channel bonding group I change controllers 1,2,3 to be channel-id 1 thru 72, and controllers 4,5,6 to also be channel-id 1 thru 72.
* The CMTS requires that every downstream channel have a unique TSID. In my case I have multiple edgeqams. Each edgeqam has 648 channels (TSID 1 through 648). To allow uniqueness on CMTS, I edited the TSIDs on edgeqam 2 to be 1001 to 1648, edgeqam2 to be 2001 to 2648, edgeqam3 to be 3001 to 3648.
* If you are wanting to feed multiple small edgeqams (eg RFGW1) from a single SPA144 you might need to consider a different design. In my case I am feeding only 1 edgeqam from each SPA, thus a /30 works fine. To feed multiple edgeqam perhaps you would need to use a larger subnet? Or I think the documentation said up to 3 subinterfaces supported, I havent tested that though.

If you are having troubles getting the tunnels to come up properly, you can try these CMTS debugging commands :
debug depi event
and/or
debug l2tp event

jenis
https://www.thewyco.com
Log in or register to post comments