Arris DG2470/3260 modem upgrade issue |

You are here

Arris DG2470/3260 modem upgrade issue

6 posts / 0 new
Last post
Arris DG2470/3260 modem upgrade issue
Image icon test.cm203.06 KB

I have recently started to dip into adjusting our modem configs from the previous docsis engineer as they were full of old stuff and the modems have never been updated. I got the DG860s to take the firmware upgrade automatically via the Enchanced Firmware Loading. The DG2470/DG3260 modems are giving me an issue though. They take about 10-15 minutes and seem to download the firmware image set aside for them in the cm file, but the modem will then reboot and it displays an error in the event log of the modem. The modem is online and functional, but firmware version never changes.

The error displayed is this:

7/31/2019 16:45 69010200 6 SW Download INIT - Via Config file
7/31/2019 17:02 69010800 4 SW upgrade Failed after download - SW File corruption
7/31/2019 17:02 2417164297 4 Touchstone SW Upgrade Failed: Provisioned upgrade;CM-MAC=38:70:0c:95:9d:6c;CMTS-MAC=00:01:5c:8a:1f:58;CM-QOS=1.1;CM-VER=3.0;

Attached is a jpg of a simple cm file i made up to try and get this EFL loading to work on our "test lab".

Any ideas? I have tried changing the tftp block size, changing the img file to a different version, re-uploading the img file in case it was corrupted, and verified the md5 sum between the version on the tftp server and the one on the dl site from arris.

The modem shows perfect signal levels of:

+4 to +5.5dbmv DS and 40 to 41db ds snr across all 24 ds channels
41.5 to 42.3dbmv across all 3 US channels with 34.3 us snr avg

any help is appreciated as I am driving myself crazy seeing as I got the dg860s to work just fine.

Thank you,
Craig D.

Have you tried the upgrade

Have you tried the upgrade with a generic Docsis upgrade rather than an Arris enhanced upgrade? There were some issues with the enhanced version when it came out.

since you using the enhanced (Arris specific) I think there is also a timeout parameter that can be configured in the config file too, the DG24xx and DG32xx modems take several minutes to upgrade.

yeah, I tried it both ways

yeah, I tried it both ways and it yields the same results of corrupted after download. I am going to try setting up a small web server to try grabbing it through http instead of tftp. hopefully going through http it will complete because i am going crazy


I'd try http as you suggested. I've had some 24 channel pace modems with quite a large firmware size repeatedly fail from timeout due to the speed of tftp, but upgrade fine over http.

http worked like a charm. 3

http worked like a charm. 3 minutes from reboot and it loaded the new firmware. ty all

jccg (not verified)
Can you attach your firmware

Can you attach your firmware file? We could really use one.

Log in or register to post comments