Bridging vs routing | docsis.org

You are here

Bridging vs routing

9 posts / 0 new
Last post
Anonymous (not verified)
Bridging vs routing

Hello,
Anybody experienced such transitions (bridging -> routing or routing -> bridging) for a cmts? I would like to have some impressions.
I just replaced a npe-400 with a npe-g1 and I think i can further reduce the processor load by putting the cmts in bridging mode.
For an ubr7246vxr with a npe-g1 I have about 43% processor load at peak hours.
1800 modems, speeds from (up/down) 128/512 to 256/2048.

thanks

Anonymous (not verified)
Bridging vs routing

Imho 43% of CPU load is normal.
Standart practice recommends to be worried about this then CPU load more than 70 %.

Talking about your situation, it`ll be good if you show results of
show proc cpu 5m
at peak hours and in the rest time. This will help us to determine what exactly loads CPU on your CMTS.

Anonymous (not verified)
Bridging vs routing

Here is the partial output of sh processes cpu sorted 5min :
-----------------------------------------------------------------------------------
CPU utilization for five seconds: 35%/34%; one minute: 35%; five minutes: 33%
PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
76 11348580 73005628 155 0.16% 0.58% 0.65% 0 IP Input
102 9975444 33952323 293 0.49% 0.59% 0.57% 0 DHCPD Receive
22 1290448 5473455 235 0.08% 0.18% 0.19% 0 ARP Input
30 690636 417821 1652 0.00% 0.05% 0.05% 0 Net Background
5 953260 152766 6240 0.57% 0.07% 0.05% 0 Check heaps
98 723948 1354026 534 0.00% 0.05% 0.04% 0 CEF process
38 632976 126085 5020 0.00% 0.04% 0.02% 0 CMTS CM MONITOR
133 388564 1004548 386 0.00% 0.04% 0.02% 0 SNMP ENGINE
131 177736 2008591 88 0.00% 0.02% 0.00% 0 IP SNMP
3 24 125 192 0.08% 0.01% 0.00% 2 Virtual Exec
97 149848 21061 7114 0.16% 0.01% 0.00% 0 Adj Manager
130 226676 21318 10633 0.00% 0.01% 0.00% 0 Per-minute Jobs
56 542232 1600710 338 0.00% 0.00% 0.00% 0 CMTS MAC Protoco
103 66004 20965 3148 0.00% 0.00% 0.00% 0 IP Cache Ager
15 17028 3583472 4 0.00% 0.00% 0.00% 0 EnvMon
14 0 2 0 0.00% 0.00% 0.00% 0 AAA high-capacit
17 0 1 0 0.00% 0.00% 0.00% 0 IPC Zone Manager
16 0 1 0 0.00% 0.00% 0.00% 0 OIR Handler
13 8 125807 0 0.00% 0.00% 0.00% 0 Compute SRP rate
20 0 1 0 0.00% 0.00% 0.00% 0 IPC Seat Manager
21 0 1 0 0.00% 0.00% 0.00% 0 IPC BackPressure
12 0 2 0 0.00% 0.00% 0.00% 0 ATM VC Auto Crea
18 240 1257910 0 0.00% 0.00% 0.00% 0 IPC Periodic Tim
19 156 1257910 0 0.00% 0.00% 0.00% 0 IPC Deferred Por
25 0 2 0 0.00% 0.00% 0.00% 0 Entity MIB API
23 1180 311893 3 0.00% 0.00% 0.00% 0 HC Counter Timer
27 312 1257889 0 0.00% 0.00% 0.00% 0 GraphIt
28 0 2 0 0.00% 0.00% 0.00% 0 Dialer event
29 0 2 0 0.00% 0.00% 0.00% 0 Critical Bkgnd
11 0 2 0 0.00% 0.00% 0.00% 0 ATM AutoVC Perio
31 368 219939 1 0.00% 0.00% 0.00% 0 Logger
32 920 1257885 0 0.00% 0.00% 0.00% 0 TTY Background
33 19572 1258521 15 0.00% 0.00% 0.00% 0 Per-Second Jobs
-----------------------------------------------------------------------------------
CPU utilization for five seconds: 21%/20%; one minute: 20%; five minutes: 22%
PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process
102 10081736 34289551 294 0.24% 0.47% 0.49% 0 DHCPD Receive
76 11473884 73756125 155 0.65% 0.44% 0.47% 0 IP Input
22 1309412 5547879 236 0.08% 0.04% 0.05% 0 ARP Input
30 698176 421632 1655 0.08% 0.02% 0.04% 0 Net Background
56 546516 1616877 338 0.24% 0.07% 0.03% 0 CMTS MAC Protoco
98 734312 1369423 536 0.08% 0.03% 0.02% 0 CEF process
5 965572 154543 6247 0.00% 0.03% 0.02% 0 Check heaps
38 641392 127533 5029 0.08% 0.02% 0.00% 0 CMTS CM MONITOR
9 0 2 0 0.00% 0.00% 0.00% 0 Serial Backgroun
10 0 2 0 0.00% 0.00% 0.00% 0 ATM Idle Timer
11 0 2 0 0.00% 0.00% 0.00% 0 ATM AutoVC Perio
12 0 2 0 0.00% 0.00% 0.00% 0 ATM VC Auto Crea
8 0 2 0 0.00% 0.00% 0.00% 0 Timers
7 0 1 0 0.00% 0.00% 0.00% 0 AAA_SERVER_DEADT
6 56 249 224 0.00% 0.00% 0.00% 0 Pool Manager
16 0 1 0 0.00% 0.00% 0.00% 0 OIR Handler
17 0 1 0 0.00% 0.00% 0.00% 0 IPC Zone Manager
4 0 1 0 0.00% 0.00% 0.00% 0 C10K Card Event
3 20 124 161 0.00% 0.00% 0.00% 2 Virtual Exec
20 0 1 0 0.00% 0.00% 0.00% 0 IPC Seat Manager
21 0 1 0 0.00% 0.00% 0.00% 0 IPC BackPressure
--------------------------------------------------------------------------------------
Not quite the peak load in there but the idea is the same.
The thing is that in maximum 3 months we plan to double the download speeds so I'm scratching my head to find out if the cmts will hold on.

Anonymous (not verified)
Bridging vs routing

What I see in your output is that your CPU has, for-example, 35% load
but your top 5 process (IP Input, DHCPD,ARP Input, Net Background) use only ~2-3 % of CPU time. And that is the most heavy process in your CMTS/router.
Making reference to Cisco IOS documentation, output
CPU utilization for five seconds: 35%/34%;
means that your total CPU load is 35%, and 34% of processor time is wasted on software interrupts (instead of normal process processing).
I mean that your router is loaded not normal IP traffic processing. Something else waste your CPU resources. :(
Either it is large ACL on your interfaces either it is additional features which you turned on.
In normal situations output of 'sh proc cpu 5m' show that for example
CPU utilization for five seconds: 35%/34%; one minute: 35%; five minutes: 33%

And sum CPU utilization of first 5-10 process = 35%/34%; one minute: 35%; five minutes: 33%.

Am I correct that you use so-called plain IP internet access, no PPPoE on router?
Btw, try to move DHCPD from Cisco to some server (unix/linux or windows). Imho moving DHCPD settings for 1800 CM away from CMTS will reduce your CPU load.

Anonymous (not verified)
Bridging vs routing

Well I have an access-list but is only 4 lines long and yes no pppoe.
The dhcp/tftp servers are on a linux machine(docsis_server).The time server it is on cmts.
The only "extra" feature I use is upstream balancing.
Maybe i should try with a leaner IOS ... the image I'm using is
ubr7200-is-mz1.122-15.BC2a.bin and it has 17 M in size.
I think it is best that you have the configuration also, at least the main parts:

cable spectrum-group 1 band 20000000 27000000
cable spectrum-group 2 shared
cable spectrum-group 2 band 20000000 27000000
cable spectrum-group 3 shared
cable spectrum-group 3 band 20000000 27000000
cable spectrum-group 4 shared
cable spectrum-group 4 band 20000000 27000000
cable modulation-profile 2 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed uw16
cable modulation-profile 2 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 2 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 2 short 5 76 7 8 16qam scrambler 152 no-diff 144 shortened uw16
cable modulation-profile 2 long 10 220 0 8 16qam scrambler 152 no-diff 160 shortened uw16
cable qos permission create
cable qos permission update
cable qos permission modems
cable time-server
cable load-balance group 1 method utilization
cable load-balance group 2 method utilization
cable load-balance group 3 method utilization
ip subnet-zero
!
!
ip cef
ip name-server xxx.xxx.xxx.xxx
ip dhcp limited-broadcast-address
ip dhcp relay information option
no mpls ldp logging neighbor-changes
!
!
!
interface Loopback0
ip address 100.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
interface shutdown
duplex half
!
GigabitEthernet0/1
ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx secondary
ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx secondary
ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
ip helper-address xxx.xxx.xxx.xxx
no ip unreachables
ip route-cache same-interface
ip route-cache policy
ip route-cache flow
no ip route-cache cef
no ip mroute-cache
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface GigabitEthernet0/3
no ip address
duplex auto
speed auto
media-type rj45
no negotiation auto
!
interface Cable3/0
no ip address
no ip unreachables
ip route-cache policy
ip route-cache flow
cable tftp-enforce
cable max-hosts 10
cable bundle 1
cable downstream annex B
cable downstream modulation 256qam
cable downstream interleave-depth 32
cable downstream frequency 250000000
cable downstream channel-id 1
cable upstream 0 power-level 0
cable upstream 0 channel-width 3200000
cable upstream 0 minislot-size 2
cable upstream 0 modulation-profile 2 1
no cable upstream 0 shutdown
.... the rest of the upstreams
cable source-verify dhcp
!
interface Cable4/0
no ip address
no ip unreachables
ip route-cache policy
ip route-cache flow
cable tftp-enforce
cable max-hosts 10
cable bundle 1
cable downstream annex B
cable downstream modulation 256qam
cable downstream interleave-depth 32
cable downstream frequency 202000000
cable downstream channel-id 1
cable upstream 0 spectrum-group 1
cable upstream 0 power-level 0
cable upstream 0 channel-width 3200000 1600000
cable upstream 0 minislot-size 2
cable upstream 0 modulation-profile 2 1
no cable upstream 0 shutdown
......
cable source-verify dhcp
!

interface Cable5/0
no ip address
no ip unreachables
ip route-cache policy
ip route-cache flow
cable tftp-enforce
cable max-hosts 10
cable bundle 1
cable downstream annex B
cable downstream modulation 256qam
cable downstream interleave-depth 32
cable downstream frequency 322000000
cable downstream channel-id 1
cable upstream 0 spectrum-group 1
cable upstream 0 power-level 0
cable upstream 0 channel-width 3200000 1600000
cable upstream 0 minislot-size 2
cable upstream 0 modulation-profile 2 1
no cable upstream 0 shutdown
....................
cable source-verify dhcp
!
interface Cable6/0
ip address ................... secondary
ip address ................... secondary
ip address ................... secondary
ip address ....................secondary
ip address ................... secondary
ip address ................... secondary
ip address ................... secondary
ip address ................... secondary
ip address ................... secondary
ip address ................... secondary
ip address 10.0.0.1 255.0.0.0
no ip unreachables
ip helper-address xxx.xxx.xxx.xxx
ip route-cache policy
ip route-cache flow
cable tftp-enforce
cable max-hosts 10

cable bundle 1 master
cable downstream annex B
cable downstream modulation 256qam
cable downstream interleave-depth 32
cable downstream frequency 362000000
cable downstream channel-id 1
cable upstream 0 spectrum-group 1
cable upstream 0 power-level 0
cable upstream 0 channel-width 3200000 1600000
cable upstream 0 minislot-size 2
cable upstream 0 modulation-profile 2 1
no cable upstream 0 shutdown
.................
cable source-verify dhcp
no keepalive
!
ip classless
..... 6 static routes
no ip http server
logging ..........
!
!
!
access-list compiled
access-list 1 permit ............
access-list 1 permit ...........
access-list 1 permit ...........
access-list 1 permit ..........
no cdp run
!
snmp-server engineID local 0000000902000007501C2C00
snmp-server community .......... RO 1
no snmp-server enable traps tty
snmp-server host .......... ............ snmp
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 3
access-class 1 in
password 7 ............
login local
line vty 4
access-class 1 in
password 7 ..............
login local
line vty 5 15
login
!
scheduler allocate 4000 400
end

And thanks for spending time with my problem..

Anonymous (not verified)
Bridging vs routing

heh, Cisco feature navigator (www.cisco.com/go/fn) sayz me when i search description of your IOS (Search By Image)

Quote:
The Image Name you entered does not match any supported Cisco software releases in this tool. Please change the Image Name and search again. Thank you.

:-D
Don`t know what to say...
Btw, recently Cisco announced new IOS version for 7200VXR with support of new NPE-G2!!! so anyway you still have the ability to increase your perfomance :)
http://www.cisco.com/en/US/products/sw/iosswrel/ps1838/prod_bulletin0900aecd80586fe2.html
I actually don`t know is NPE-G2 compatible with UBR7246VXR, but for 7204VXR,7206VXR it is. AFAIK UBR7246VXR based on the same platform.

Anonymous (not verified)
Bridging vs routing

Btw, have you seen your GE inetrface traffic load?
sho int $EXTERNAL-IFACE | in rate

for example,
sh int gi 1/24 | in rate
5 minute input rate 131335000 bits/sec, 19209 packets/sec
5 minute output rate 168709000 bits/sec, 26381 packets/sec

what is interested me in your config

GigabitEthernet0/1
no ip route-cache cef

that is not a good idea to disable CEF

Anonymous (not verified)
Bridging vs routing

Here it is:
sh int GigabitEthernet 0/1 | in rate
Queueing strategy: fifo
5 minute input rate 38697000 bits/sec, 6566 packets/sec
5 minute output rate 14832000 bits/sec, 6065 packets/sec

FIxed no ip route-cache cef thing.
Thanks

Anonymous (not verified)
Bridging vs routing

NPE G2 is not supported on ubr7246 vxr :
http://www.cisco.com/en/US/products/hw/routers/ps341/products_installation_guide_chapter09186a008054edec.html
I found why DHCPD was eating resources :).lots of voice modems with their mta's trying to aquire ip addresses. The CMTS did not forward the requests..only when i used the cable monitor command I has able to see the problem.