Unable to run CASA C2200 in 16x4 | docsis.org

You are here

Unable to run CASA C2200 in 16x4

4 posts / 0 new
Last post
Kiloohm
Unable to run CASA C2200 in 16x4
AttachmentSize
Plain text icon c2200_running-config.txt10.95 KB

Hello,

I'm trying to run a C2200 in 16x4 but I can't seem to get the configuration right. Regardless of what I do, modems will only come online in 8x4 mode.

Wondering if I'm missing something obvious here. This is for lab/testing environment but I'd like to get this part right.

I've attached my running config to this post and show system / version below if it is relevant.

CASA-C2200#show system
Product: C2200, Module: SMM
Major rev 1, Minor rev 1
serial_no = SV03BA1S0004
CFE version 2.1.5
System Time: Fri Nov 2 22:28:14 CET 2018
System Uptime: 0 d, 0 h, 15 m, 56 s
128MHz T1 Clock

Module 0 QAM Running (4 ports, 4 channels/port, 1 banks/port, docsis enabled)
Major rev 4, Minor rev 1
serial_no = QV48BA6S0413
CFE version 2.1.5

Module 1 UPS Running (8 ports, 2 phy chans/port, 1 log chans/phy chan, scdma map 00)
Major rev 3, Minor rev 0
serial_no = UV30B98S0197
CFE version 2.1.5
CASA-C2200#show version
Running Image: SMM Rel 6.1, Ver 2,build27, Fri Aug 24 18:27:53 EDT 2012,(relmgr)
Configured boot device: flash2
flash1: SMM Rel 5.4, Ver 21.Build28, Fri Sep 16 15:29:39 EDT 2011, ( relmgr)
flash2: SMM Rel 6.1, Ver 2,build27, Fri Aug 24 18:27:53 EDT 2012, ( relmgr)
CFE Boot: Major 2, Minor 1, Build 5

Your help is much appreciated...

cmcaldas
bonding group

your running slightly lower software release, but notice your missing bonding group. try adding that to see if it resolves the issue and let everyone know.

example:
bonding-group downstream mac-domain 1 group-id 1
qam 0/0/0
qam 0/0/1
qam 0/1/0
qam 0/1/1

bonding-group upstream mac-domain 1 group-id 1
upstream 1/0.0/0
upstream 1/1.0/0
upstream 1/2.0/0
upstream 1/3.0/0

bonding-group downstream mac-domain 2 group-id 2
qam 0/2/0
qam 0/2/1
qam 0/3/0
qam 0/3/1

bonding-group upstream mac-domain 2 group-id 2
upstream 1/4.0/0
upstream 1/5.0/0
upstream 1/6.0/0
upstream 1/7.0/0

Kiloohm
No joy, still have all my

No joy, still have all my modems running 8x4 (they are all D3.1 capable with 32x8 SC-QAM)

CASA-C2200#show bonding-group

bonding-group upstream mac-domain 1 group-id 1
upstream 1/0.0/0
upstream 1/1.0/0
upstream 1/2.0/0
upstream 1/3.0/0
prov-attr-mask 0x80000000

bonding-group downstream mac-domain 1 group-id 1
qam 0/0/0
qam 0/0/1
qam 0/0/2
qam 0/0/3
qam 0/1/0
qam 0/1/1
qam 0/1/2
qam 0/1/3
qam 0/2/0
qam 0/2/1
qam 0/2/2
qam 0/2/3
qam 0/3/0
qam 0/3/1
qam 0/3/2
qam 0/3/3
prov-attr-mask 0x80000000
reseq wait-time 180
reseq warn-thrshld 0
CASA-C2200#show downstream channel set
MAC Chan Channel
ID Set List
1 1 0/0/0
1 2 0/0/1
1 3 0/0/2
1 4 0/0/3
1 5 0/1/0
1 6 0/1/1
1 7 0/1/2
1 8 0/1/3
1 9 0/2/0
1 10 0/2/1
1 11 0/2/2
1 12 0/2/3
1 13 0/3/0
1 14 0/3/1
1 15 0/3/2
1 16 0/3/3
1 256 0/0/0, 0/0/1, 0/0/2, 0/0/3, 0/1/0, 0/1/1, 0/1/2, 0/1/3, 0/2/0, 0/2/1, 0/2/2, 0/2/3, 0/3/0, 0/3/1, 0/3/2, 0/3/3
1 257 0/0/0, 0/0/1, 0/0/2, 0/0/3, 0/1/0, 0/1/1, 0/1/2, 0/1/3
CASA-C2200#show upstream channel set
MAC Chan Channel
ID Set List
1 1 1/0.0/0
1 2 1/1.0/0
1 3 1/2.0/0
1 4 1/3.0/0
1 5 1/4.0/0
1 6 1/5.0/0
1 7 1/6.0/0
1 8 1/7.0/0
1 256 1/0.0/0, 1/1.0/0, 1/2.0/0, 1/3.0/0
CASA-C2200#scm bon
MAC Address MAC US DS US DS US CHAN and DS CHAN
id Intf Intf SET SET EXCLUDED EXCLUDED
00fc.8d57.36d1 1 1/0.0/0 0/0/2 256 257
1cab.c007.53d0 1 1/3.0/0 0/0/2 256 257
8494.8c6a.d3e0 1 1/0.0/0 0/0/0 256 257
9050.caae.74c0 1 1/0.0/0 0/1/0 256 257
a84e.3f37.03c2 1 1/2.0/0 0/0/0 256 257
a84e.3f37.03ec 1 1/3.0/0 0/0/0 256 257
ac20.2e0f.0300 1 1/2.0/0 0/0/2 256 257
ac20.2e12.f0c0 1 1/0.0/0 0/0/0 256 257
ac20.2e13.3d60 1 1/2.0/0 0/0/2 256 257
ac20.2e7b.4780 1 1/1.0/0 0/0/2 256 257
f81d.0fd1.9050 1 1/0.0/0 0/0/3 256 257

CASA-C2200#scm ac20.2e7b.4780 phy
MAC Address US IF DS IF Sid USPwr(dB) USSNR Timing MicroReflec DSPwr DSSNR Mode
TX RX (dB) Offset (dBc) (dB) (dB)
ac20.2e7b.4780 1/0.0/0 0/0/2 4 40.3 0.0 42.1 2440 38 1.0 43.3 atdma
ac20.2e7b.4780 1/1.0/0 0/0/1 4 40.3 -0.5 42.1 2441 38 1.2 43.3 atdma
ac20.2e7b.4780 1/2.0/0 0/0/0 4 40.3 0.0 42.1 2441 38 1.2 44.6 atdma
ac20.2e7b.4780 1/3.0/0 0/0/3 4 39.5 0.0 42.1 2440 38 1.0 43.3 atdma
ac20.2e7b.4780 - 0/1/0 4 - - - - 36 1.2 41.6 -
ac20.2e7b.4780 - 0/1/1 4 - - - - 35 1.2 43.3 -
ac20.2e7b.4780 - 0/1/2 4 - - - - 36 1.4 43.3 -
ac20.2e7b.4780 - 0/1/3 4 - - - - 38 1.5 43.3 -

cmcaldas
-attr-mask 0x80000000

notice you have -attr-mask 0x80000000 in the config. is it in the modem file?
I know on the C4 modems didn't bond upstream until I added it to the modem file. in this case it may be needed on the downstream.
example of it on the upstream in modem file, required attribute

SNMP MIB Object(docsDevNmAccessStatus.1):1.3.6.1.2.1.69.1.2.1.7.1, Integer, 4
Network Access Control:on
Upstream Service Flow Encodings
Service Flow Reference:1
Quality of Service Parameter Set:provisioned admitted active
Traffic Priority:0
Upstream Maximum Sustained Traffic Rate:50000000
Maximum Traffic Burst:40000
Maximum Concatenated Burst:30000
Service Flow Required Attribute Mask:80000000
Downstream Service Flow Encodings
Service Flow Reference:2
Quality of Service Parameter Set:provisioned admitted active
Traffic Priority:0
Downstream Maximum Sustained Traffic Rate:150000000
Maximum Traffic Burst:30000
Maximum Number of CPEs:5
Enable 2.0 mode:on
SNMP MIB Object(docsDevNmAccessControl.1):1.3.6.1.2.1.69.1.2.1.5.1, Integer, 2
SNMP MIB Object(docsDevNmAccessInterfaces.1):1.3.6.1.2.1.69.1.2.1.6.1, Octet String, @
SNMP MIB Object(docsDevNmAccessCommunity.1):1.3.6.1.2.1.69.1.2.1.4.1, Octet String, xxxxxxxxx
SNMP MIB Object(docsDevNmAccessStatus.2):1.3.6.1.2.1.69.1.2.1.7.2, Integer, 4
SNMP MIB Object(docsDevNmAccessControl.2):1.3.6.1.2.1.69.1.2.1.5.2, Integer, 3
SNMP MIB Object(docsDevNmAccessInterfaces.2):1.3.6.1.2.1.69.1.2.1.6.2, Octet String, @
SNMP MIB Object(docsDevNmAccessCommunity.2):1.3.6.1.2.1.69.1.2.1.4.2, Octet String, xxxx