Cisco Network Registrar Freeze !!!! | docsis.org

You are here

Cisco Network Registrar Freeze !!!!

6 posts / 0 new
Last post
Anonymous (not verified)
Cisco Network Registrar Freeze !!!!

Hi everyone!!

I am using Cisco Network Registrar(CNR) 5.5.13 for DHCP server.

but sometimes these program (CNR) freeze.

So i checked windows event viewer. There are some warning and errors like below.

AIC Server Agent 2.0

Server name /dhcp/1:0 option
'DHCP_O_VENDOR_ENCAPSULATED_OPTIONS'
not found in Policy!

Server name /dhcp/1:0
Database lock attempt failed, err -917

The 'Cisco Network Registrar User's guide' says

Step 1. See your DHCP client device vendor's manual for the device's class identifier string that the client sends
in DHCP option 60. Use this string in the vendor-option name create command. The following command creates the device1_vso vendor option,using the exact string that the vendor uses for the device's class identifier.
The class identifier must be unique to each vendor option.

nrcmd> vendor-option device1_vso create "device1:Arch:xxxxxx:UNDI:yyyzzz"

I want to know DHCP client device's class identifier string.(What is that mean Arch, UNDI...?)

we use several kind of Cable modem (CM) like motorola(SB5100), CastleNet(DP1110XB2A) and Etc.

Is there any know bug that could cause this behaviour?
Any help is very appreciated.

Thank You in advance

ps. Sorry for my poor english

kwesibrunee
I doubt the vendor

I doubt the vendor encapsulated options not being found is the cause of your freezes

when you say freeze, what do you mean, the GUI (graphical user interface) freezes or the server process freezes. i.e. Does the gui become non-responsive, or does the server stop handling dhcp requests?

With cisco's cnr, I would look at the server logs as well as the windows event viewer to try and figure out the problem.

Server name /dhcp/1:0
Database lock attempt failed, err -917

looks very much like it could be your problem, cnr uses BDB (berkeley db) as its db engine so that would be a place to look.

BDB is file based so maybe you have disk corruption or a drive that is failing....

jonathan (not verified)
Hi! kwesibrunee

Hi! kwesibrunee

Thank you for your advice.

Freeze that means dhcp server stop handling for client request.

Here is a another errors,

Server name/dhcp/1:0 Unknown MCD error :
0x8006005 when trying to configure binary data:
/server/name/dhcp/1/cliententry/ (here is a our client cable modem MAC)

And aiclockmgr.exe error that is unexpected practical application error.

I doubt the program file(aiclockmgr.exe) that has own fault or corrupt windows system or other applications.

There is any bug report aiclockmgr.exe ..?

Any help is very appreciated.

ps) Sorry for my poor english.

kwesibrunee
aiclockmgr is a database

aiclockmgr is a database file locker, not 100% sure what mcd is

We have not used the windows version of CNR for a while now but both of your probs seem to me to indicate one of two problems, or a combination of the two.

1. Hardware problems -- Bad hard drive, bad ram etc.....

2. File corruption

Really only way I see to try and rememdy the problem is to get a test machine install the same version of CNR on to it.

With all CNR services stopped on both machines copy the data directory to the new machine to replace its data directory. The cnr should then start on the new machine if the problem goes away it is likely a hardware problem, if problem persists likely culprit is file corruption, in which case you will need to reinstall cnr and reconfigure it.

If I had to guess the problem, I would think bad ram, which has led to file corruption.

jonathan (not verified)
We used two kind of Server.

We used two kind of Server. (Primary Server and Secondary Server)

The Main Server(primary) is made by DELL company. (POWER EDGE 1800 MODEL)

For a month ago we change ram 512MB to new 1GB. so i think there is no problem about ram.

And the other server (secondary) is self-assembled Server.

If Main server has a problem, we move main server data to secondary one.

Two of them has same problem (CNR Freeze !!), so i think there is no hard drive problem.

I don't know what is the problem about our Server !!!

Any help is very appreciated.

kwesibrunee
What version of CNR are you

What version of CNR are you using?

Are you using cnr's failover? If so perhaps it is misconfigured and causing the probs.

Since you are just moving the data to other one data corruption is still a possiblity, possibly due to faulty ram on primary server , I would reccommend running memtest86 or similar on primary server.

Other than that don't have much to offer you we have not ran the windows version of CNR for quite a while all my experience with it is on linux/solaris