Docsis 3.0 emta's registering to CMTS as Docsis 2.0 ? | docsis.org

You are here

Docsis 3.0 emta's registering to CMTS as Docsis 2.0 ?

2 posts / 0 new
Last post
martian_rob
Docsis 3.0 emta's registering to CMTS as Docsis 2.0 ?

Just wondering if anyone has seen this? We're scratching our heads on this one and the CMTS and CM vendors are in denial that it can even occur but the 'scm verbose' below proves otherwise and this particular modem has been confirmed as a Docsis 3.0 mac version CG3000 emta.
What we are finding is that after a scheduled EQAM outage is restored, usually as part of a node groom , approximately 1/3 of the CG3000 fleet register as D2.0 and hence enter narrowband Online(pt) instead W-Online(pt) wideband. Problem with this of course is that the modems cannot be then be detected with 'scw' command and are effectively 'hidden' amongst the rest of the regular narrowband D2.0 modems and customer is speed capped on a single DS. They can be picked out using 'scw registered-traditional-docsis' and then reset to restore them to W-Online(pt), but it would be nice to get to the root cause of why it is occurring. I just cannot reproduce the problem in lab conditions.
Any hints or clues appreciated. I suspect there is a Broadcom patch for it somewhere !

D
MAC Address IP Address I/F MAC Prim RxPwr Timing Num I
State Sid (dBmv) Offset CPE P
7444.01e3.28b0 10.57.254.5 C6/0/1/U1 online(pt) 7871 1.00 1708 1 N

#scm 10.57.254.5 ver

MAC Address : 7444.01e3.28b0
IP Address : 10.57.254.5
IPv6 Address : ---
Dual IP : N
Prim Sid : 7871
Host Interface : C6/0/1/U1
MD-DS-SG / MD-US-SG : N/A / N/A
MD-CM-SG : 0x1F0001
Primary Downstream : C6/0/1 (RfId : 504)
Wideband Capable : N
RCP Index : 0
RCP ID : 00 10 00 00 04
Multi-Transmit Channel Mode : N
Upstream Channel : US1
Ranging Status : sta
Upstream Power (dBmV) : 0.00
Upstream SNR (dB) : 36.12
Received Power (dBmV) : 1.00
Timing Offset (97.6 ns): 1708
Initial Timing Offset : 1708
Rng Timing Adj Moving Avg(0.381 ns): 128
Rng Timing Adj Lt Moving Avg : 30
Rng Timing Adj Minimum : 0
Rng Timing Adj Maximum : 256
Pre-EQ Good : 0
Pre-EQ Scaled : 0
Pre-EQ Impulse : 0
Pre-EQ Direct Loads : 0
Good Codewords rx : 109511
Corrected Codewords rx : 0
Uncorrectable Codewords rx : 0
Phy Operating Mode : atdma
sysDescr :
Downstream Power : 0.00 dBmV (SNR = ----- dB)
MAC Version : DOC2.0
QoS Provisioned Mode : DOC1.1
Enable DOCSIS2.0 Mode : Y
Modem Status : {Modem= online(pt), Security=assign(tek)}
Capabilities : {Frag=Y, Concat=Y, PHS=Y}
Security Capabilities : {Priv=BPI+, EAE=N, Key_len=56}
L2VPN Capabilities : {L2VPN=N, eSAFE=N}
Sid/Said Limit : {Max US Sids=16, Max DS Saids=15}
Optional Filtering Support : {802.1P=N, 802.1Q=N, DUT=N}
Transmit Equalizer Support : {Taps/Symbol= 1, Num of Taps= 24}
Number of CPE IPs : 1(Max CPE IPs = 16)
CFG Max-CPE : 2
Flaps : 1(Oct 25 01:57:11)
Errors : 0 CRCs, 0 HCSes
Stn Mtn Failures : 0 aborts, 0 exhausted
Total US Flows : 4(4 active)
Total DS Flows : 4(4 active)
Total US Data : 78570 packets, 15656655 bytes
Total US Throughput : 47018 bits/sec, 61 packets/sec
Total DS Data : 64121 packets, 14769442 bytes
Total DS Throughput : 30810 bits/sec, 37 packets/sec
LB group ID assigned (index) : N/A (N/A)
LB group ID in config file (index) : N/A (N/A)
LB policy ID : 0
LB policy ID in config file : 0
LB priority : 0
Tag :
Required DS Attribute Mask : 0x0
Forbidden DS Attribute Mask : 0x0
Required US Attribute Mask : 0x0
Forbidden US Attribute Mask : 0x0
Service Type ID :
Service Type ID in config file :
Active Classifiers : 12 (Max = NO LIMIT)
CM Upstream Filter Group : 0
CM Downstream Filter Group : 0
CPE Upstream Filter Group : 0
CPE Downstream Filter Group : 0
DSA/DSX messages : permit all
Dynamic Secret : A0D36F12F6AABB07E937285B39A34A09
Voice Enabled : YES
DS Change Times : 0
Boolean Services : 1
Number of Multicast DSIDs Support : 16
MDF Capability Mode : 0
IGMP/MLD Version : IGMPv2
FCType10 Forwarding Support : N
Features Bitmask : 0x0
Total Time Online : 05:29
CM Initialization Reason : T4_EXPIRED
CFG Max IPv6 CPE Prefix : 16 (-1 used)
thorn2.cm#

CMTS : Cisco ubr10012 running SCD7 ios, configured as an M-CMTS
EQAM : Cisco RFGW-1
emta's : Netgear CG3000

Capm
cause

I think this is caused by the modem trying to automatically adjust to the loss of the channels, and falling back into a kind of worst-case mode. Its possible a firmware upgrade would help this issue if they are running older firmware, depending on the models you see doing this, if the modems aren't rebonding on their own, or the other possibility is, after you perform your maintenance and bring the qams back up, clear all the modems from the cmts, and force them to re-register at that time.